PDA

View Full Version : Uniden Pro 520XL Issues



WCreighton
10-12-2019, 08:31 AM
Hi all,

Iím running a Uniden Pro 520XL with a Firestik II 3 foot antenna. Recently Iíve had a few issues. Sometimes my mic wonít key up and then other times it will. Sometimes Iíll turn on my radio and the volume will be really low, then it will return to normal. Usually all channels will have the same volume level, but lately some channels have been a lot louder than others. Could someone help me out with some troubleshooting?

222DBFL
10-12-2019, 09:06 AM
Check your antenna connections. Could be an issue with either the antenna itself, or the coax and/or the connectors. Check for kinks in the coax and make sure your connectors are good and donít have any issues. Could be a piece of shield is touching center pin as well.

JesseJamesDallas
10-12-2019, 09:19 AM
If fixing the coax or replacing the Mic doesn't fix the problem...Just chunk the radio and buy another one...It would cost more to fix that radio at a CB Shop, than it's worth...You can get a new one for between 40-50 bucks.

WCreighton
10-13-2019, 01:37 PM
Thanks for the replies guys.

I think it’s an issue with the mic. Whenever the radio isn’t working like normal, I talk into the mic even though it isn’t keying up, once I stop talking the radio starts to work like normal again and the mic works. Has anyone experienced an issue like this or can confirm it’s the mic?

Thanks,
Will

JesseJamesDallas
10-13-2019, 09:43 PM
I've had mic issues with my President McKinley where I could key the mic and nothing happen...switch in the mic was wore out.

Good thing about the Uniden 520's, is any 4 pin mic wired for Cobra/Galaxy radios will work on it...So you can go to your nearest truck stop, buy any mic wired for a 4-pin cobra/galaxy radio and it will work with your 520...