View Full Version : CB makes noise when trucks in reverse???

12-21-2016, 07:02 PM
This is my first post. I'm new to the CB world. I got a Uniden pro505xl off amazon for Christmas. Set it up on my truck with a 3 foot firestik, 18 foot coax. For power I used a fuse tap, then grounded to the frame. I had trouble tuning at first, but after raising the antenna a little bit I have an SWR reading of 1.7 all round. Here's the issue, when I put my truck into reverse it makes a ton of white noise!!! Also, I'm getting a whine from it as well coming from interference with the alternator. This is really bugging me. I checked grounds, they are okay and just for kicks I put a second ground onto the antenna mount going to the frame of the truck. Please Help!!!

08-06-2017, 04:20 AM
you got a back up camera or warning tone

08-06-2017, 04:23 AM
the noise is coming from the cb speaker, or the stereo speakers

08-06-2017, 07:59 AM
I had similar issues an ran my power straight off of the battery....both positive and negative.......solved all the noises for me....now that's the only way I will hook them up....goodluck! ......427 omaha....backin down

08-07-2017, 02:34 AM
your not going to like what im gonna say but I will anyway. choke choke choke find you a couple of big ones put on both the positive and negative, not next to each other, then whatever dedicated ground wire you've got run from antenna to framed. cut it as short as possible to make the ground connection. if you can keep it 4 or 5 feet that would be ideal much longer and risk getting it resonant to the coaxial cable length

08-07-2017, 04:00 AM
Yup.....that works as well.....ounds like what we discussed when I was in those classes about tricity n stuff

10-18-2017, 02:13 AM
you can also use 30 amp or 40amp noise suppressor.work great.it normally using in sound system but an be use other wise. running the wire is good to but the noise suppressor can work even better.