preps
Results 1 to 4 of 4

Thread: Meters not working on Uniden Madison

  1. #1
    Join Date
    Apr 2019
    Location
    PA
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Downloads
    0
    Uploads
    0

    Meters not working on Uniden Madison

    I just bought an old Madison, 8719 pll, analog clock.

    Ive been out of the game for a long time.

    It powers up, transmits and recieves, at least from my garage to my driveway--I dont even have a jumper to put the watt meter inline yet, but I can say that its not dead as a doornail anyway.

    The meters do not move, at all. Even when I key up in the driveway with my mobile, nothing on the S meter. The other meter is the same, no movement whatsoever.

    Is there something common to both meter's operation that I should be looking at? Any ideas about which direction to go as far as the meters go?

    Much more to do--controls are scratchy, some of the variable resistors look sort of, not corroded, but tarnished? Ill have to get some cleaner for that sort of stuff.

    The clock does not work, not a big deal.

    There is a capacitor in the back that is broken--like literally 1/3 of it is just gone---one of the flat tan units, not a can--Ill have to track that down as well. Im not sure if theres enough of the number left on that one to ID it, Ill have to get a mirror to check since its up against the back wall.

    Anyway, thanks in advance for any input!!!

  2. #2
    Join Date
    Apr 2018
    Location
    Oklahoma
    Posts
    104
    Thanks
    0
    Thanked 21 Times in 19 Posts
    Downloads
    0
    Uploads
    0
    1st off the meters are more than likely dirty from age. if you pull them out you can see a small screw at the pivot point. take a small screw driver and work the screw out wards just a very little then back in just a little to loosen up the pivot point. just turn the screw out bound maybe 1/16 of a turn and no more. just slight movement of the screw should let the needle start working again. get some good electronics cleaner for the front controls since you said they are scratchy.
    look on the main board for the number marked for the capacitor that is bad. we more than likely can find what cap you need by the board number.
    you said the parts are dirty on the board so spray them with a cleaner then scrub them lightly with a tooth brush to loosen the dirt up. spray it off before it drys to get the dirt off. you can also get a can of air to spray off the dirt. just do not use to much pressure if you have an air compressor instead of canned air.
    if the bad cap is a tantalum cap you can replace it with a electrolytic cap of the same values in most cases.
    this should get you started in the right direction. with the age of the radio all the electro caps should be changed out do to there age so they do not short out and damage other parts that are harder to find since you said the radio is some what working. electro caps dry out with age and cause all kinds of problems so change them before you start having other problems.

  3. #3
    Join Date
    Apr 2019
    Location
    PA
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Downloads
    0
    Uploads
    0
    Thanks! I got the meters freed up! Not sure if they exactly make sense yet though.
    The broken capacitor is C192, pic follows.....some of the marking is gone.
    Next time I get out, I will get some electronics cleaner and start cleaning things up.


  4. #4
    Join Date
    Apr 2018
    Location
    Oklahoma
    Posts
    104
    Thanks
    0
    Thanked 21 Times in 19 Posts
    Downloads
    0
    Uploads
    0
    the cap looks like a 104. looks like the 1 in front is all that is missing.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •