preps
Results 1 to 4 of 4

Thread: Connex

  1. #1
    Join Date
    Jan 2020
    Location
    Harrisburg,Pa
    Posts
    19
    Thanks
    1
    Thanked 3 Times in 3 Posts
    Downloads
    0
    Uploads
    0

    Connex

    I was cleaning out my shop the other day and came across an old Connex 3600 hp radio. I tried hooking it up in my Jeep Wrangler and as soon as I push the push to talk button I get a loud squeal. Maybe this is the reason I wasn't using it. I hooked it up in my basement using an inverter and a short antenna and I talked to a guy 5 miles away. Anybody have any ideas what to do here?

  2. #2
    Join Date
    Jan 2019
    Location
    N/E PA
    Posts
    499
    Thanks
    212
    Thanked 110 Times in 96 Posts
    Downloads
    86
    Uploads
    0
    check your mic button for sticking or need cleaning. Spray your contacts where your mic plugs into the radio with contact cleaner. Stuff setting around develops corrosion. I think I remember that happening to me once. You made a contact so it is probably something small.

  3. #3
    Join Date
    Jan 2012
    Location
    Republic of Texas
    Posts
    753
    Thanks
    99
    Thanked 494 Times in 308 Posts
    Downloads
    0
    Uploads
    0
    Turn off the talkback...or turn down the Mic Gain...


  4. #4
    Join Date
    Jan 2020
    Location
    Harrisburg,Pa
    Posts
    19
    Thanks
    1
    Thanked 3 Times in 3 Posts
    Downloads
    0
    Uploads
    0
    You know what worked, I unpluged the external speaker and the squeal was gone. I will turn the talkback down and play with the mic gain. Thanks for the advise Guys

  5. The Following User Says Thank You to Ted For This Useful Post:

    whiteastro (01-27-2020)

Visitors found this page by searching for

None

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •