preps
Results 1 to 6 of 6

Thread: Flickering headlights...

  1. #1
    Join Date
    Nov 2021
    Location
    Appomattox, VA
    Posts
    30
    Thanks
    0
    Thanked 6 Times in 6 Posts
    Downloads
    0
    Uploads
    0

    Flickering headlights...

    I might give this a try on my crew cab...with my flickering 2004 Silverado crew cab headlights while talking on radio with my 2pill turned on...

    Check this out on Amazon
    NEW 250 AMP HIGH OUTPUT ALTERNATOR FITS VARIOUS CHEVY TRUCKS SILVERADO SUBURBAN 2002-2007 4.3L 4.8L 5.3L 5.7L 6.0L 6.5L 6.6L 8.1L WITH 4 PIN REGULATOR PLUG CONNECTOR https://smile.amazon.com/dp/B06VWZQ1...ing=UTF8&psc=1

    I thought it was from my dying 5yr old battery, but it's still doing it with the new Interstate MTP-78 battery...I don't remember having this issue last yr when DST switched...

    Maybe I have a dying alternator that killed my 5yr old battery?

    Sent from my motorola one 5G UW ace using Tapatalk

  2. #2
    Join Date
    Jan 2012
    Location
    Republic of Texas
    Posts
    811
    Thanks
    113
    Thanked 518 Times in 329 Posts
    Downloads
    0
    Uploads
    0
    Could be the alternator...thats a good price for a 250 amp...

    Tho i have never seen headlights "flicker" from power drain...Usually they just dim...flickering could be stray RF messing with the lights.


  3. #3
    Join Date
    Nov 2021
    Location
    Appomattox, VA
    Posts
    30
    Thanks
    0
    Thanked 6 Times in 6 Posts
    Downloads
    0
    Uploads
    0
    I've got ferrite chokes on alternator wires, power wire to amp and radio...course they may not be correctly sized as it was a choke kit from AMZ.

    Power wire straight from battery. Ground for radio & amp is connected in two places in cab, one on bolt that holds gas pedal to firewall and other is one of studs that driver's seat bolts to the floor. Antenna mount is fender mount also with ground to frame.

    May try another choke kit for some more of them and add a couple to the mic wiring...

    Sent from my motorola one 5G UW ace using Tapatalk
    Last edited by GobblerK5; 11-17-2021 at 04:15 PM.

  4. #4
    Join Date
    Jan 2012
    Location
    Republic of Texas
    Posts
    811
    Thanks
    113
    Thanked 518 Times in 329 Posts
    Downloads
    0
    Uploads
    0
    Are these aftermarket LED or Halogen lighting headlights?

    Some of those type light kits just don't work with CB set-ups running amps.


  5. #5
    Join Date
    Nov 2021
    Location
    Appomattox, VA
    Posts
    30
    Thanks
    0
    Thanked 6 Times in 6 Posts
    Downloads
    0
    Uploads
    0
    Nope...not LED headlights...plain ol Sylvania bulbs in some RockAutocat eye housings...

    My alternator is charging as I get higher volt reading on battery while engine is running...

    I read on SilveradoSierradotcom forum that the voltage regulator in alternator could cause flickering lights, but that was all the time. Mine only flicker with the 2pills being juiced...

    You may be onto something with RF causing the flickering... But nothing has changed in my setup since last time change when I was commuting home from work in the dark...

    Sent from my motorola one 5G UW ace using Tapatalk

  6. #6
    Join Date
    Feb 2014
    Location
    West coast
    Posts
    150
    Thanks
    0
    Thanked 107 Times in 66 Posts
    Downloads
    0
    Uploads
    0
    The newer cars, since '96 can be really problematic with all the sensors and computers onboard when adding a little extra wattage. The only cure would be to split the alternator output and connect a second battery just for the amp and the addition of a larger alternator would help too. But the RF is still going to do strange things to all that solid state.

Visitors found this page by searching for

None

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •